High load on carrier service causing partial API availability

Incident Report for Karla

Resolved

High traffic on the morning of November 20th caused temporary issues with our carrier integration services, which impacted trigger functionality.

We've identified and addressed the issues that caused the problem, and set up improved autoscaling to handle big traffic spikes efficiently.

---
Timeline (UTC)

November 20, 06:47 — Investigating
Reports of carrier API errors during morning traffic spike.

November 20, 07:21 — Identified
High load on carrier services that put constraint on our auto-scaling service.

November 20, 08:05 — Monitoring
Load decreased as traffic normalized. Monitoring for data loss.

November 20, 08:27 — Update
Confirmed some notification events were not properly sent during peak period. Services returning to normal.

November 20, 09:25 — Resolved
Issue has been resolved. We continue monitoring to ensure stability.

Affected Components: Carrier Integrations, API Services, Shipment Tracking
Posted Nov 20, 2025 - 07:00 UTC