Increased amount of errors when submitting notifications to Klaviyo

Incident Report for Karla

Resolved

All internal alerts have been automatically closed and the incident is now resolved.
Posted Feb 15, 2025 - 09:58 UTC

Monitoring

All Klaviyo events have been processed, some of them with significant delays this morning. We are keeping a close eye to make sure that there are no new validation errors.
Posted Feb 15, 2025 - 09:51 UTC

Identified

The regression has been identified and we are planning preventive measures to avoid it from happening in the future.
Posted Feb 15, 2025 - 09:50 UTC

Update

A fix has been deployed and systems are able to process new events on time. We are still reprocessing old events that have been piled up due to the validation errors.
Posted Feb 15, 2025 - 09:42 UTC

Investigating

We are currently investigating why Klaviyo has an increased amount of validation errors, affecting the triggers sent to Klaviyo customers.
Posted Feb 15, 2025 - 09:12 UTC