Degradation of API service due to heavy load in the database

Incident Report for Karla

Postmortem

We have significantly scaled up our database to be able to deal with peaks of traffic, and optimized the db queries.

Posted Feb 07, 2024 - 07:53 UTC

Resolved

We experienced degradation of service in our API service due to very heavy load in our database. Incident was resolved at 3:30PM UTC once the database was scaled up with more resources.
Posted Jan 15, 2024 - 15:00 UTC